Home » Android » WhatsApp ha una falla, aggiornatela subito!

WhatsApp ha una falla, aggiornatela subito!

Se avete ricevuto qualche gif strana su WhatsApp da qualche vostro amico, potreste aver incontrato un bel problema, e speriamo per voi che non la abbiate aperta: a quanto pare stanno girando alcune gif “malevoli” in grado in sfruttare una vulnerabilità della famosa app di messaggistica per veicolare codice malevolo.

A scoprirlo un hacker di Singapore (“Awakened“), il quale ha trovato la falla ad agosto ed è stato pagato da WhatsApp per questo. In pratica, la gif serve per sfruttare un bug nella libreria immaginilibpl_droidsonroids_gif.so” che permette l’esecuzione di uno shellcode e di eseguire un attacco remoto.

In pratica il programma che gestisce le immagini va in crash e, cercando di leggere il codice per far ripartire il programma, legge il codice depositato dall’hacker, potendo così avviare sistemi come spyware o malware.

A cosa può aver accesso l’hacker? Un po’ tutto, dai dati personali, ai codici e alle password. Ma non solo: può anche prendere il controllo del dispositivo per eseguire attacchi DDOS esterni.

LEGGI ANCHE: 7 giorni senza le Google App

Fortunatamente il “problema” è limitato: l’exploit può essere sfruttato solo nelle versioni di Android 8.1 e 9.0, e la problematica è stata sistemata grazie all’aggiornamento di WhatsApp 2.19.244. Vi consigliamo dunque di aggiornare immediatamente la vostra applicazione!

L’articolo WhatsApp ha una falla, aggiornatela subito! sembra essere il primo su AndroidWorld.

Powered by WPeMatico

admin

Lascia un commento

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.

Optimization WordPress Plugins & Solutions by W3 EDGE